Delays of Manual Review and Support Response
Incident Report for Novecore
Resolved
This incident has been resolved.
Posted Apr 16, 2020 - 10:27 UTC
Identified
Due to Coronavirus we are experiencing delays in manual reviews and responses to support requests.
Posted Apr 03, 2020 - 10:00 UTC
This incident affected: Quality Control.