Because of increased amounts of uploads manual review might take slightly longer than usual
Incident Report for Novecore
Resolved
This incident has been resolved.
Posted Feb 29, 2020 - 13:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 27, 2020 - 19:58 UTC
This incident affected: Quality Control.